Por favor, lee nuestro Aviso sobre el uso del material contenido en éste Artículo.

Tras 65 semanas de desarrollo y con un poco de dudas, Linus Tovarld anunció la liberación de la versión definitiva del núcleo, versión 2.6.39.

Algunas de sus mejoras desde la versión 2.6.38:

  • La inclusión de los drivers Nouveau para tarjetas Nvidia que prometen superar el rendimiento del driver propietario, como ya sucediera con las Ati en el Kernel 2.6.38, aunque en el segundo caso defraudó un poco, dado a las expectativas creadas.
  • Mejoras en el sistema de archivos EXT4.
  • Soporte para los nuevos chips gráficos de AMD o los chips GMA500 y WLAN de la serie Intel 2000.
  • Soporte para WiFi Realtek RTL8192CU y RTL8188CU.
  • Soporte para USB 3.0.
  • Controlador WMI para los nuevos netbooks ASUS.
  • Mejoras en interfaces de SCSI, entre otras.

 

Instalación:

Comprobamos el Kernel que tenemos instalado con:

$ uname -a

Nos dará algo como esto:

Linux portatil 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
Agregamos el repositorio y actualizamos
$ sudo add-apt-repository ppa:kernel-ppa/ppa
$ sudo apt-get update

y ahora instalamos

$ sudo apt-get install linux-headers-2.6.39-0 linux-headers-2.6.39-0-generic linux-image-2.6.39-0-generic
Reiniciamos la maquina
$ sudo reboot

Una vez reiniciada, verificamos que el nuevo nucleo este funcionando:

$ uname -a
Linux portatil 2.6.39-0-generic #5~20110427-Ubuntu SMP Wed Apr 27 17:41:08 UTC 2011 i686 i686 i386 GNU/Linux

 

Por k0bra

11 comentarios en «Actualizar el kernel a 2.6.39 en Ubuntu 11.04»
  1. Gracias por la info, pero no funciona:

    Paso 0:
    # uname -a
    Linux miserver 2.6.38-8-server #42-Ubuntu SMP Mon Apr 11 03:49:04 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

    Paso 1 tal como se indica:

    # add-apt-repository ppa:kernel-ppa/ppa
    Executing: gpg –ignore-time-conflict –no-options –no-default-keyring –secret-keyring /etc/apt/secring.gpg –trustdb-name /etc/apt/trustdb.gpg –keyring /etc/apt/trusted.gpg –primary-keyring /etc/apt/trusted.gpg –keyserver hkp://keyserver.ubuntu.com:80/ –recv 800AA67AE64A6D9E1859C561A8267963484B044F
    gpg: requesting key 484B044F from hkp server keyserver.ubuntu.com
    gpg: key 484B044F: public key “Launchpad PPA for Ubuntu Kernel PPA” imported
    gpg: no ultimately trusted keys found
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)

    Paso 2:

    # apt-get install linux-headers-2.6.39-0 linux-headers-2.6.39-0-generic linux-image-2.6.39-0-generic
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se ha podido localizar el paquete linux-headers-2.6.39-0
    E: No se pudo encontrar ningún paquete con la expresión regular «linux-headers-2.6.39-0»
    E: No se ha podido localizar el paquete linux-headers-2.6.39-0-generic
    E: No se pudo encontrar ningún paquete con la expresión regular «linux-headers-2.6.39-0-generic»
    E: No se ha podido localizar el paquete linux-image-2.6.39-0-generic
    E: No se pudo encontrar ningún paquete con la expresión regular «linux-image-2.6.39-0-generic»

    Saludos

  2. a mi tampoco me funciona antes si me funcionaba pero ahora nooo cmo le puedo hacer me dice lo mismo y ya puse el “apt-cache showpkg linux-headers” y no me aparece el 2.36.9-0 hay solo los anteriores yo utilizo ubuntu 11.04 espero me puedan ayudar gracias segui todos lso pasos y asi le hacia antes y si me funcionaba pero ahora no la otra es instalarlo bajando el kernel de la pagina de kernel pero la vdd n ose como compilar e instalarlo gracias …. 🙂

  3. Muchas gracias por responder.

    Si, solamente omití indicarlo.

    Hoy estuve intentando de nuevo y no, sigue con lo mismo.

    También instalé otro paquete, el sshfs y tuve problemas con el repositorio mexicano, pero usando el modificador –fix-missing del apt-get pude instalarlo. Ignoro si la instalación del kernel nuevo tenga el mismo problema al tratar de bajarse del repositorio mencionado pero tratando con el mismo modificador, tampoco funciona. Tal vez en dicho respositorio esté disponible el paquete. Tampoco sé como cambiar el sitio en que busca el apt-get.

    De todas maneras, agradezco nuevamente y esperaré unos días para volver a intentar.

    1. He publicado una actualizacion de la entrada con otro metodo de actualizacion.
      Probarlo, yo lo he actualizado hace unos minutos sin problemas.
      Si tuvierais cualquier problema no dudeis en contactar.
      Saludos

  4. yo tampoco he podido actualizar me sale el mismo error que Agustin Lopez y ya hice todos los pasos
    ese error me sale también de otras guias pero ninguna dice como arreglarlo
    k0bra
    cual es la actualización que has publicado?(no la encuentro jeje)

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.